Verpex
← Back to status

Email Connectivity Issues - s2928.can1.stableserver.net

Resolved Jul 20, 2026 17:09 UTC

Incident Updates

  • Resolved Jul 20, 2026 17:44 UTC

    The issue affecting email services on s2928.can1.stableserver.net has been resolved. Thank you for your patience and understanding. If you have any questions or require further assistance, please don't hesitate to contact our Support Team.

  • Investigating Jul 20, 2026 17:09 UTC

    We are currently investigating an issue affecting email services on the s2928.can1.stableserver.net server Some customers may experience intermittent interruptions when accessing their email via IMAP or POP3. Our team is actively working to identify the root cause and restore normal service as quickly as possible. If you have any questions, please don't hesitate to contact our Support Team.